Lab 9 Notes – FrontPage 2000 Database Connectivity

1. The first place to start learning about FrontPage 2000 database connectivity is to start FrontPage 2000 and select Help from the dropdown menu. Select Microsoft FrontPage Help. Select the Contents tab then expand the “What’s New” selection. Click “Working with databases”. Then click on the graphic for some general information.

2. Next go to Help/Microsoft FrontPage Help ( Answer Wizard ( type in “database connections” and click search. Select “Use an Access database in a web” as topic to display. This tells you how to get connected. The select “Create a database connection” to find out how to set up the web page.

3. For additional information on FrontPage 2002 go to the Microsoft demo: http://www.microsoft.com/frontpage/evaluation/demo.htm Select the database interface wizard. 
4. Show a simple example on my web page of Access Contacts. Shows five functions I want in their projects.

5. User permission requirements for a database ASP to run:

a) “Read & Execute”, “List Folder Contents”, “Read” permissions in the “D:\Program Files” subdirectory.

b) “Read & Execute”, “List Folder Contents”, “Read”, and “Write” permissions in the “D:\Winnt”subdirectory and its subdirectories 

c) “Read & Execute”, “List Folder Contents”, “Read” permissions for the specific file and in the “fpdb” subdirectory. 

d) If you give IUSR_computername or Everyone permissions in the above directories there is no authentication required for any pages. Later you can go back and change the permissions for specific pages to restrict use of those pages. This is a security whole. 
6. For lab 9, download example.mdb from the IS 4506 Home Page to a subdirectory like D:\Inetpub. (Almost any directory except D:\Inetpub\wwwroot\asp will do). Do not download example.mdb directly into D:\Inetpub\wwwroot\asp; the database connection will not be created correctly.

7. Startup FrontPage 2000. Select the asp web created in lab 8.

8. File/Import Click on Add File. Add the file example.mdb from your My Documents directory. Click OK. The Add Database Connection box will appear. Type in “example” as the name of the connection. Click OK. When it asks if you want to put the file in a new folder called “FPDB” click on yes.

9. You have created a pointer named “example” to the example.mdb file.

10. This procedure can be used for any other database files you wish to use import them as well.

11. Note the “example.mdb” file is now located in the subdirectory “fpdb”. Also note the new file: global.asa.
12. To create a simple page to display a table within a database:

a) Within the FrontPage asp web create a new HTML page. Make sure your cursor is in the new page window.

b) From the tool bar select Insert/Database/Results. The Database Results Wizard pops up. (Note this is step one of a five step wizard)

c) Note you can select which pointer you want to use. The default is the FrontPage pointer you just created but you can also select ODBC pointers or create a new pointer.

d) Use the existing database connection “example” and click “Next”.

e) (Step 2) Select Record Source “Customers” This selects the Customers table form the example.mdb file. For information click on Custom Query Edit to see how you can create your own SQL query. 

f) Click Next

g) (Step 3) Click the Edit List button

h) Select which fields you want to display. Then click “OK”.

i) Click on the More Options button to see the advanced features we can use later.

j) Click Next

k) (Step 4) Accept the default settings. Click Next

l) (Step 5) Click the “Display all records together” radio button.

m) Click Finish

13. Note the display on the page. You can modify numerous attributes as any HTML page.

14. File/Save As “display.asp” 

15. You are ready to test the page now at: http://localhost/asp/display.asp. Note - ASP will not run in the preview tab of FrontPage 2000. You must go through the browser to use the IIS ASP engine.

16. Remember the user must have specific permissions in D:\Inetpub\wwwroot\asp and D:\Winnt for the ASP to work. 

17. Go back into FrontPage and modify display.asp – You can modify the Column Titles and change colors etc.

18. Next modify the actual query in FrontPage 2000 by right clicking in the results area and selecting “Database Results Properties”. This will bring up the Database Results Wizard. Modify your query. See the results. Remember to save your results before checking it in the browser.

19. The results from above are used to display a predefined search.

20. Next, we will learn how to allow the user to input parameters that will be used in a table search. (Query).

a) Create a new page in FrontPage 2000. 

b) Go the menu and select Insert/Database/Results. The Database Results Wizard will come up.

c) Accept example and click next (Step 1)

d) Accept Customers and click next (Step 2)

e) Edit list to pick which fields to display (Step 3)

f) Click on More Options/Criteria/Add

g) From Pull down menu select FirstName and “or” OK

h) Click on Add and select LastName OK and then OK and OK

i) Then click on Next to go to step 4 then step 5

j) For step 5 select the radio button “Display all records together” and make sure the “Add search form” box is checked. 

k) Click on Finish

l) File/Save as query.asp
m) Check it out at: http://localhost/asp/query.asp
Note: If you want to query with just the first couple letters of the first or last name, in step “g” and “h” from above choose “Begins With” instead of “Equals” in the “Comparison” drop down box. To keep all the records from appearing when you first call the page, enter some Default values for First Name and Last Name like”???” from the More Options/Defaults button in Step 3. Don’t use “???” for numbers though. You can also change the message returned when there are no records in your query. In step 3 of the Database Results Wizard click on More Options. There is an input box on the form that appears that allows you to change the result displayed. 

21. Next we will learn how to input data into a table. With FrontPage 2000 we can do this on one web page:
a) Create a new page in FrontPage 2000. We will add textboxes for data field entries and then send the data directly to the database.

b) Insert/Form/One-Line Text Box. Note that there is a dotted box that contains the textbox and the Submit and Reset buttons.  Position the cursor before the text box and enter the words “First Name”. After the textbox and before the “Return” button, hit the return key a couple of times to allow room for a couple more textboxes. Now go back and Insert/Form/One-Line Text Box to add another box and put the words Last Name before it. Now we have two data fields to enter information.

c) Double click on each textbox and use the names fname and lname for the textboxes.

d) Right click anywhere inside the dotted box and select Form Properties. We will point to the database we want to send the information by selecting the “Send to database radio button” then clicking on the Options button. Make sure “example” is in the drop down box labeled “Database connections” and that Customers is in the drop down box labeled “Table to hold form results”.

e) Next click on the Saved Fields tab. Both of the textbox names will appear. We need to associate the textboxes with specific fields in the table Customers.

f) Select fname and click on Modify. Select FirstName from the dropdown box and OK.

g) Do the same thing for lname and LastName. OK/OK/OK.

h) Now save the web page as input.asp
i) Check it out at http://localhost/asp/input.asp Note the results page that is sent back to you.

j) Go back to http://localhost/is4506/asp/display.asp to ensure that your information was actually entered into the database.

k) If you get an error of “no permissions” then either you don’t have NTFS permissions to run the DLL in D:\Winnt or to write to D:\Inetpub\asp\fpdb\example.mdb

Note: When entering data directly into a database you can designate specific web pages that are returned if the input was successful or not. In the input.asp page right click within the dotted lines. Click on “Form Properties/Options” There will two text boxes that will allow you to enter a pointer to different web pages – confirmation page and error page. However the values in the input boxes will not be available on either of these pages. 

22. Next we will learn how to delete a record in a table:

a) Create a new page in FrontPage 2000. 

b) On a new page, on the Insert menu, point to Database, and click Results.

c) In step 1, select the Use an existing database connection (example) radio box, and click Next.

d) In step 2, select Customers as the Record Source, and then click Next.

e) In step 3, click Next.

f) In step 4, select List - one field per item in the Formatting list and Text fields in the List options list, and then click Next.

g) In step 5, click Split records into groups, and type 1 in the Records per group box. Click Finish.

h) Double-click the Submit button, and change the Value/Label field to Delete.

i) Right-click inside the form, and click Form Properties.

j) In Form Properties, click the Send to other button, and then click Options.

k) In the Action field, type delete.asp. Click OK twice and then save the page as delete_form.asp.

l) Create a new page. (On the File menu, point to New, click Page, and click Normal Page.)

m) On the Insert menu, point to Database, and click Results.

n) In step 1, click the Use an existing database connection button, and select example. Click Next.

o) In step 2, click the Custom query button, and then click Edit. In the SQL statement window, type the following SQL code: 

DELETE DISTINCT from Customers

WHERE CustomerID=::CustomerID::
p) Click OK and then click Next. 

q) In step 3, click Next.

r) In step 4, select Table-One Record Per Row and then click Next.

s) In step 5, click the radio button “Display all records together” and make sure the Add search form check box is not selected. Click Finish and then save the page as delete.asp.

NOTE: The field name CustomerID represents the field used in the example.mdb file. The field ::CustomerID:: represents the one-line text box form field. If the input box brought in a string value then it would be enclosed with a single apostrophe (i.e. ‘::Name::’).

23. Go to http://localhost/asp/delete_form.asp and try it. 

24. Finally we will learn how to update a record from a table:
a) Create a new page in FrontPage 2000. 

b) On a new page, on the Insert menu, point to Database, and click Results.

c) In step 1, select the Use an existing database connection (example) radio box, and click Next.

d) In step 2, select Customers as the Record Source, and then click Next.

e) In step 3, click Next.

f) In step 4, from the drop down box select List - one field per item in the Formatting list and Text fields in the List options list, and then click Next.

g) In step 5, click Split records into groups, and type 1 in the Records per group box. Click Finish.

h) Double-click the Submit button, and change the Value/Label field to Update.

i) Right-click inside the form, and click Form Properties.

j) In Form Properties, click the Send to other button, and then click Options.

k) In the Action field, type update.asp. Click OK twice and then save the page as update_form.asp.

l) Create a new page. (On the File menu, point to New, click Page, and click Normal Page.)

m) On the Insert menu, point to Database, and click Results.

n) In step 1, click the Use an existing database connection button, and select example. Click Next.

o) In step 2, click the Custom query button, and then click Edit. In the SQL statement window, type the following SQL code: 

UPDATE customers SET  FirstName='::FirstName::',LastName='::LastName::',Address='::Address::',City='::City::',State='::State::',ZipCode='::ZipCode::',PhoneNumber='::PhoneNumber::'

WHERE CustomerID=::CustomerID::

p) Click OK and then click Next. 

r) In step 3, click Next.

r) In step 4, select Table-One Record Per Row and then click Next.

t) In step 5, make sure the Add search form check box is not selected. Click Finish and then save the page as update.asp.

NOTE: No Customer fields can be empty when the update button is clicked!
25. Go to http://localhost/asp/update_form.asp and try it.

Additional Notes

1. Don’t use spaces in your table field names. In some instances it causes errors.

2. Don’t use spaces in your table names. In some instances it causes errors.

3. There are several Additional Fields that can be added to your database table when sending form inputs directly to a database (i.e. Timestamp). After completing your input ASP:

a) Right click in the results section

b) Select Form Properties
c) Select the radio button “Send to database”.

d) Click on the Options button.

e) Click on the Additional Fields tab and select the fields you want automatically inserted into your database.
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