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Section 4 

USER INTERFACE 

 
4.1  WINDOWS TERMINOLOGY 

 

This section discusses much of the terminology used in describing a Windows-based 

environment.  An understanding of this terminology will make the remaining portions of 

this manual easier to follow.  Additionally, since all Microsoft Windows-based 

applications follow the same format, Sections 4.1, 4.2, and 4.6 are applicable to other 

programs as well. 

 

The Windows environment is comprised of windows, dialog boxes, and various types of 

bars.  The following sub-sections explain these features. See Section 6.4 for instructions 

on starting ASSET from the Windows environment. 

 

4.1.1  Windows 

 

The working platform within a Windows-based application consists of one or more 

windows.  These windows contain all other features of the program.  Within the 

windows, menu choices are made, dialog boxes appear, text is entered, program features 

are run, etc.  The following figure contains the main window of ASSET.  Within this 

main window, all of ASSET's features can be accessed. 
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Figure 4.1 ASSET’s Main Window 

 

Figure 4.1 is ASSET's main window.  Located inside this window are three additional 

windows arranged in an overlapping, cascade-formation.  Each window serves a specific  

function.   Windows can be moved and resized to the preference of the user.  For more 

information on windows, refer to Section 4.2.2. 

 

4.1.2  Bars 
 

Bars are objects located within the main window that contain information and tools that 

can be readily accessed by the user.  ASSET's main window (Figure 4.1) has four bars, 

three situated at the top of the window, and one at the bottom.  The first bar is the title 

bar.  Every window, whether a main window or an auxiliary window, has a title bar.  The 

title bar contains the name of the program or the name of the window, with the 

highlighted title bars indicating what windows are active.  Additionally, a title bar may 
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include information pertaining to a current file name, etc.  In Figure 4.1, since there are 

four windows, there are four title bars: ASSET, Graphic Reports, Printed Reports, and 

Messages. 

The second type of bar is the menu bar.  This bar contains pull or drop-down menu 

choices.  With a pull-down menu bar, clicking on a menu bar label (a word) will pull 

down a sub-menu of additional choices germane to the menu bar label.  ASSET uses 

pull-down menus. Drop-down menus function like a pull-down menu except that the sub-

menus will automatically drop down without the need of clicking; just pointing the 

mouse arrow at a menu option will activate a sub-menu.  In Figure 4.1, the main window 

has a menu bar- across, it reads: File, Edit, Module, Ship, Databank, Utilities, Options, 

View, Window, and Help.  Pointing the mouse arrow and clicking on any one of these 

words will pull down a sub-menu. 

 

The third type of bar is the tool bar.  In Figure 4.1 the tool bar is directly below the menu 

bar.  A tool bar contains buttons that perform various commonly used program functions.  

Leaving the mouse’s indicator over a tool will allow for the tool icon’s functional 

description to appear.  Clicking on a tool bar button will perform its programmed 

function. 

 

The fourth type of bar is the status bar.  The status bar is located across the bottom of the 

window.  In this bar is a listing of information about the status of the program.  Number 

and capital lock key status is shown, messages describing the selected menu and tool bar 

buttons are displayed on the left.  The ASSET status bar also shows which program is 

running (MONOSC, etc.), the name of the current model, and the status of the program 

(i.e. READY, GRAPH, BUSY).  GRAPH indicates that the program is in the graphics 

mode and is waiting to display the next graphic.  READY and BUSY indicate the status 

of the program to accept new commands. 
 

 

 

4.1.3  Dialog Boxes 
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Whenever ASSET requires additional information to carry out a command chosen from 

the drop-down menus, a dialog box will appear.  Depending on the information needed, a 

dialog box will contain various types of controls used for input of the data.  Figures 4.2a 

and 4.2b show a sample of ASSET's dialog boxes.  Their major components have been 

labeled.  

 

 
Figure 4.2a Sample Dialog Box
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Figure 4.2b Sample Dialog Box 
 

Radio Buttons - Radio buttons are used to present two or more mutually exclusive 

choices.  To activate a radio button, click on the desired choice's circle.  A black dot will 

appear in the circle when it is activated. 

 

List Box - List boxes allow the user to select from a list of options (such as a list of files, 

etc.).  If the list is long enough, a scroll bar will be located to the right of the box, 

enabling the user to scroll through the choices. (See scroll bar definition.)  To select a 

choice, either double-click the entry or click once to highlight it, then choose the 

appropriate command button (e.g. OK). 

 

Text Entry Box - Some options require the user to type information.  If the box is empty, 

click inside the box to obtain a cursor, then begin typing.  If the box already contains text, 

clicking inside the box will highlight the text.  Typing text will replace the pre-existing 
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text.  To delete the text, press the backspace button on the keyboard.  To accept the pre-

existing text, simply click on the appropriate command button. 

 

Check Box - Check Boxes are used to enable and disable an option.  The option is 

enabled when an X appears in the box and disabled when the box is empty.  Clicking on 

the box will enable/disable the option. 

 

Drop Down List Box - These boxes present a list of choices when the user clicks on the 

arrow to the right of the box.  After clicking the arrow, a list box appears and the user can 

select an option in the same fashion as a list box.  See Figure 4.9 for an additional 

example. 

 

Title Bar - Like windows, dialog boxes are labeled with a title bar.  The title bar usually 

lists the menu choice from which the dialog box was activated. 

 

Command Button - Command buttons cause a specific action to occur.  The action is 

labeled on the button.  Some command buttons, when pressed, will bring the user to 

another dialog box. 

 

Scroll Bar/Slider/Arrows - This structure appears when the information to be contained in 

a list box consumes more space than the list box can display.  Clicking the scroll arrows 

will move the list up or down, showing additional options not originally displayed.  The 

scroll bar indicates where the user is in relation to the entire list.  By clicking on the 

scroll box and keeping the left mouse button depressed, the user can dynamically scroll 

through the list by sliding the scroll box up or down.  By clicking on the scroll bar 

(instead of clicking on the arrows or scroll box), the user can automatically scroll the list 

one incremental step, showing the next block of options in sequence. 
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Numeric Entry Boxes - These boxes are used to enter numeric values.  The user can 

either type the number after clicking in the box, or the user can scroll through the values 

in numeric order by clicking the up or down arrow buttons. 

 

OK/ Cancel Buttons - The OK button is used to carry out a specified action.  The Cancel 

button closes the dialog box without performing any options that might have been chosen 

by the user. 

 
4.2  USING WINDOWS 

 

This sections deals with techniques that will enable the user to work with Windows 

applications (specifically ASSET) as efficiently as possible.  For a full description of the 

Windows environment and its characteristics, refer to an MS-Windows User Guide. 
 

4.2.1  Help Files 

 

Like any Windows application, ASSET has a menu option labeled "Help."  Within the 

Help menu, the user can find on-line documentation pertaining to the User Interface, 

ASSET Parameter Definitions, ASSET Commands and User Manuals on each ASSET 

module.  Specific help topics can be accessed using the standard Windows Contents, 

Index and Find dialogs.  Pressing the  button and then highlighting a command from 

the menu bar will provide help on the topic. 
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Figure 4.3 Running ASSET with a Help File 

 

4.2.2  Manipulating Windows 

 

ASSET has three output windows: Messages, Printed Reports, and Graphic Reports (see 

section 4.4 for a description of these windows).  Depending on the type of data to be 

output, data will be sent to these windows during an ASSET session.  When ASSET is 

first started, these three windows are arranged in an overlapping cascade-fashion.  The 

user can change this configuration.  Each window can be moved and/or resized. 

 

To move a window, click on the window's title bar and keep the left mouse button 

depressed.  The window can now be moved around the screen.  To resize a window, 

move the mouse arrow to the edge of the window.  The mouse arrow will turn into a 

double arrow, showing the directions in which the window's edge can be moved.  To 
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resize the window, when the double arrow is activated, click and hold down the left 

mouse button.  Move the window's edge to the desired location, and then release the 

mouse button.  If the mouse arrow is positioned in the corner of a window, a double 

arrow will appear indicating that the both the horizontal and vertical edges can be moved 

simultaneously.  This method is faster than resizing a window in the horizontal and then 

in the vertical. 

 

In addition to moving and resizing windows, ASSET will allow the user to automatically 

arrange, cascade or tile the three output windows.  When ASSET is first run, the output 

windows are cascaded.  Each window can be brought to the front by clicking the mouse 

in the desired window.  From “Window “ Command in the Menu Bar an additional 

option is available to tile the windows.  This option takes the three output windows and 

arranges them so they all have equal space within the main window.  Figure 4.4 shows all 

four options.  With any arrangement, the windows can be moved and resized by the user.  

To retain a customized window arrangement for following ASSET sessions, select Save 

Window Positions from the Options menu located in the menu bar. 
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Automatic Arrangement 

 
Cascade (default) 

 
Horizontal Tiling 

 
Vertical Tiling 

Figure 4.4 Window Arrangement Options 

 

4.2.3  Application Switching  & Copying 

 

During an ASSET session, Windows will allow the user to run additional applications, 

such as a word processor, spreadsheet, etc.  This option allows the user to use ASSET 

output in an application without exiting from ASSET.  All currently executing 

applications are visible in the Task Bar (Fig 4.5), usually located at the bottom of the 

screen.  Selecting one of the applications will switch the context to that program.  

 
Figure 4.5 Task Bar 
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4.2.4  Desktop Publishing 

 

Windows features a network of applications that aid in the transfer of screen-displayed-

information.  For example, if an ASSET user wants to include an ASSET-generated 

graphic in a word processing document, the user can copy the ASSET graphic to the 

clipboard, edit it in a drawing program, then paste it into the word processing document.  

This capability makes the presentation of ASSET output particularly flexible. 

 

Two options exist for transferring information from ASSET to other applications. The 

user can either highlight the text or graphics with the mouse and COPY  (located in the 

EDIT menu of any Windows Application) the block to the Windows Clipboard, or the 

user can depress the PRINT SCREEN key located on the keyboard.  COPYing 

highlighted text to the clipboard can be used in conjunction with the Messages and 

Printed Reports output windows.  Here, highlighting text and issuing the COPY menu-

command (EDIT, COPY or CNTL C) will send the text to the Windows Clipboard.  

Upon entering any Windows application that supports edit commands, the text can be 

pasted (click the Clipboard/Paste icon) to the application data. 

 

If the user wants to send a graphic from the Graphic Reports window to the clipboard, 

the same methods as for Messages and Printed Reports windows can be used.  From the 

clipboard, the user can PASTE (located in the EDIT menu of Any Windows application) 

the clipboard contents to a drawing program for image editing or PASTE the image 

directly into the target program (Word, PowerPoint, etc.). 

 

Refer to an MS-Windows Users Manual for additional information on Windows' desktop 

publishing features.  Another good source of information is the Windows Help included 

with Windows 95 or Windows NT. 
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4.3  ASSET'S MAIN WINDOW  
 

ASSET's main window is the working platform for the executive program.  Within the 

main window, the following items are present: title bar, menu bar, tool bar, three output 

windows, and a status bar.  From this main window, any portion of ASSET's capabilities 

can be accessed.  Figure 4.8 shows ASSET's main window.  A discussion of its 

components follows. 

 

 
Figure 4.8 ASSET’s Main Window 
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4.3.1  Title Bar  

 

The uppermost portion of ASSET's main window is the title bar.  The main window is 

labeled with the word ASSET and the name of the active output window.  The title bar is 

highlighted because the main window is active (the window is ready to accept user 

input). 

 

4.3.2  Menu Bar 

 

Just below the title bar is the menu bar.  Under each of the menu headings is a sub-menu, 

each filled with commands used to send commands to ASSET.  Clicking on a menu 

heading with the left mouse button will drop down the associated sub-menu.  See Section 

4.5, Tour of the Menus, for additional information. 

 

4.3.3  Tool Bar 

 

Below the menu bar is the tool bar.  The tool bar contains buttons programmed to 

perform important and commonly used ASSET commands and functions.  Following is a 

description of the tool bar's features. 

 

 Reinitialize Reinitialize the Current Model, Log File or Settings 

Menu Equivalent: File⇒New 

Command String Equivalent: REINITIALIZE, {ALL, CURRENT MODEL, LOG FILE, 

SETTINGS} 

 

 Use Use a Ship or Component 

Menu equivalent: File⇒Open or Ship⇒Use 

Command String Equivalent: USE, ship name or USE, component name 
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 Modify  Modify a Ship or Component in the Databank 

Menu Equivalent: File⇒Save or Ship⇒Modify   

Command String Equivalent: MODIFY, ship name or MODIFY, component name 

Note:  This button can be used to store a ship to the data bank for the first time or modify 

an existing ship in the databank. 

 

 Cut  Cut the selection and put it on the Clipboard 

Menu Equivalent: Edit⇒Cut 

 

 Copy  Copy the selection and put it on the Clipboard 

Menu Equivalent: Edit⇒Copy 

 

 Paste  Insert Clipboard contents 

Menu Equivalent: Edit⇒Paste 

 

 Erase  Erase the selection 

Menu Equivalent: Edit⇒Clear 

 

 Print  Print the active document 

Menu Equivalent: File⇒Print 

 

 About  Display program information, version number and copyright 

Menu Equivalent: Help⇒About ASSET/Win 

 

 Help  Display Help for clicked on button, menu and window 
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4.3.4  Command Text Box 

 

  
This is the Command Text Box.  It is located in the tool bar, to the right of the command 

buttons.   This box is where the user issues all ASSET commands when entering them in 

command-string-format (instead of menu-commands).  The user clicks the left mouse 

button in the box to bring up the cursor, then types the command string.  To the right of 

the Command Text Box is an arrow.  The Command Text Box is a drop-down list box.  

Clicking on the arrow will drop down the Command Buffer, which stores previously 

issued commands.  Highlighting a command from the list and pressing the issue 

command button (to the left of the command text box) will issue that command.  Figure 

4.9 shows an example of a buffer displayed from the Command Text Box.  

 
Figure 4.9 Command Text Box with Buffer 

 

All commands issued from the Menu or Tool Bar are recorded in the Command Buffer.  

The Command Buffer is particularly useful when issuing repetitious commands. 
 

4.3.5  Output Windows 
 

When starting an ASSET session, three output windows will appear: Messages, Printed 

Reports, and Graphic Reports.  Each window displays a different type of ASSET output.  

The contents of any output window can be cut or copied to the Windows Clipboard, 

erased during a session, or sent to a printer.  The user can scroll though the window by 

using the scroll bar/box/arrows structure located on the right portion of the window. 
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The Messages window displays messages sent from the executive program to the user.  

Typical output are program error messages, menu choices after the user has entered query 

(or prompt) mode, command confirmations, and echoes of the commands entered by the 

user.  Figure 4.10 shows the Messages window. 

 

 

 
Figure 4.10 Messages Output Window 

 

The Printed Reports window displays textual information generated by ASSET's 

modules.  The information is sent to the window in the form of Reports.  The user can 

select which reports are sent to the Printed Reports window by issuing the following 

menu command, Module⇒Select Reports, then choosing the desired reports from the 

Select Output Reports dialog box (shown in Figure 4.11).  Figure 4.12a shows the 

Printed Reports window.  
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Figure 4.11 Select Output Reports Dialog Box 

 

 
Figure 4.12a Printed Reports Output Window 
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The Graphic Reports window serves the same purpose as the Printed Reports window, 

but displays graphical output.  The user can specify reports to be sent to the window 

using the same means described for the Printed Reports window.  Note:  If the user has 

requested more than one graphical report, only one graphic is displayed at a time.  

Clicking the left mouse button will cause the next graphic report to be displayed, 

overwriting the previous one.  Additionally, each report must be viewed before 

continuing the ASSET session.  Figure 4.12b shows the Graphic Reports window. 

 

 
Status Bar Figure 4.12b Graphic Reports Window 

 

4.3.6  Status Bar 

 

The status bar is located at the bottom of ASSET's main window.  Figure 4.12 shows an 

example of typical information displayed in the bar.  On the left is ASSET's status  
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message, telling the user that it is waiting for the user to press a key to continue.  This 

portion of the bar also tells the user when ASSET is busy.  Other messages are displayed 

here as well.  For example, when the user clicks on a tool bar button, a description of the 

button's function is displayed. 

 

To the right of ASSET's status message is the program indicator.  This box displays the 

user's program choice.  In Figure 4.12b, the user is running MONOSC. 

 

The next box is the current databank indicator.  This box displays the name of the 

currently attached databank.  In Figure 4.12b, the current databank is msc460.bnk. 

 

Next is the current model indicator.  This box displays the name of the current model.  In 

figure 4.12b, the current model's name is FLIGHT I. 

 

The next box displays the program mode.  The program mode can be READY, BUSY, 

EDIT or GRAPH.  READY means ASSET is ready for a new command.  BUSY 

indicates ASSET is executing a command.  EDIT signals ASSET is in the Editor.  

GRAPH indicates a Graphic Report is displayed and ASSET is waiting to go to the next 

graphic. 

 

The last boxes display the status of the Caps Lock, Num Lock and Scroll Lock keys.  If 

NUM appears in the status bar, the Number Lock key is activated.  If CAP appears in the 

status window, the Caps Lock key is activated.  If SCRL appears in the status window, 

the Scroll Lock key is activated. 
 

4.4  TOUR OF THE MENUS 
 

This section describes ASSET's menu bar and all the commands contained within the 

pull-down menu.  Each sub-menu is examined in the order in which they appear on the 

screen, from left to right.  Where applicable, the ASSET command string corresponding 

to the menu-command is given.  The user should watch the command text box while 
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issuing menu-commands since the ASSET-command-string-equivalent appears in the 

text box after the menu-command has been issued.  This practice will help the user 

understand both forms of command input. 

 

4.4.1  File Menu 

 

The file menu, which is common to all Windows applications, is first on the menu bar.  

Figure 4.13 shows the contents of the File menu.  This menu is used to perform file 

manipulation and associated tasks.  In the ASSET context, a "file" is related to a ship or 

ship component. 

 

Note:  In certain instances, the File menu does not pertain to ships/ship components.  On 

the initial start-up of ASSET, a file dialog box is displayed to prompt the user to select a 

data bank.  If a data bank is not selected and the CANCEL button is pressed (to close the 

dialog box), the File menu will be related to data bank "files."  From this menu, the user 

can create a new data bank. 

 

 

Figure 4.13 File Menu
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NEW- this command is used to reinitialize the current model, ASSET settings, and/or log 

file.  After clicking on NEW, a dialog box asks the user, via check boxes, to select 

portions to reinitialize.  This command can be used to clear the workspace and start with 

a new current model.  ASSET command: REINITIALIZE 

 

OPEN- this command is used to include a ship or a ship component as part of the current 

model.  A dialog box appears, asking the user to select a ship or ship component from the 

attached data bank.  The data stored in the data bank corresponding to the user's selection 

will be added to the current model.  The user can also use this command to use a single 

parameter or group of parameters.  ASSET command: USE 

 

SAVE/SAVE AS- these commands save the current model or a component to the 

attached data bank. A dialog box appears, prompting the user to indicate whether the item 

to be saved is an entire ship or a ship component.  If it is a component, the user can pick 

from the Model Parameter List, indicating what parameter or group of parameters is to be 

saved.  ASSET command: STORE 

 

REMOVE- this command deletes a ship or ship component from the attached data bank.  

ASSET command: REMOVE 

 

PRINT- this command prints the active output window. 

 

PRINT PREVIEW- this command show how the active window will be printed.  Two 

pages can be displayed at one time.  Zoom In, Zoom Out, and Print command buttons are 

located in the print preview screen. 

 

PRINT SETUP- this command generates a dialog box that contains the available printer 

options. 
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4.4.2 Edit Menu 
This menu, like the File menu, is common to all Windows applications.  Figure 4.14 

shows the Edit menu.  This menu is used for desktop publishing purposes and window 

editing.  Additionally, the ASSET editor is accessed through this menu. 

 

 
Figure 4.14 Edit Menu 

UNDO- this command allows the user to undo the previous command. 

CUT- this command takes a selected portion of an output window and sends it to the 

Windows clipboard.  From the clipboard, the user can direct the text and/or graphics to 

other Windows applications. 

COPY- this command performs the same function of the CUT command, except the 

highlighted portion of the window is copied to the clipboard instead of being removed 

from the output Window and sent to the clipboard. 

PASTE- this command allows the user to paste clipboard data into the active window. 

CLEAR- this command allows the user to clear the current selection. 

SELECT ALL- this command allows the user to select everything in the active window. 

OPEN EDITOR- the options allows the user to enter model data via the spreadsheet 

editor. (See Section 4.5)  Section 4.5.1 shows the menu that appears after the user has 

chosen OPEN EDITOR.  The user may enter/edit data for the entire ship, a particular 

group of parameters, or a single parameter. 
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PAYLOAD AND ADJUSTMENTS- this command takes the user to the Payload and 

Adjustments edit window. 

MANNING AND ACCOMONDATIONS- this command takes the user to the Manning 

and Accommodations edit window. 

TRUNKS – this command takes the user to the Trunks edit window. 

SPONSONS – this command takes the user to the Sponsons edit window. 

 

 

4.4.3     Module Menu 

Figure 4.16 shows the Module menu.  From this menu the user can run any or all I/O, 

synthesis, and analysis modules.  The user can also select which output reports are sent to 

the output windows. 

 

 
Figure 4.16 Module Menu 

 

RUN-  selecting this command will call up a dialog box that allows the user to choose 

from the entire list of modules (Figure 4.17).  From this box, the user can run any 

module, including the synthesis loop.  By using the INCLUDE command buttons, the 

user has the option of excluding and including any synthesis modules from the loop, prior 

to running synthesis.  By highlighting a selection with the mouse, the user selects the 

desired module.  Clicking on OK runs the module.  It is possible to toggle the Include 

box such that a module is “on” with an “γ” in the box and the module is “off” with a 

blank box.  The REPORTS button brings the user to the dialog box where output reports 
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are selected to be sent to the output windows.  This is the same dialog box as the one 

generated using the SELECT REPORTS menu-command in the File menu.  See section 

4.5.1. 

 

 
Figure 4.17    Run Module Dialog Box 

 

SYNTHESIS-  this command runs ASSET's synthesis loop.  Any modules that have been 

excluded from the loop are not run. 

 

SELECT REPORTS- this command is used in conjunction with running one or more 

modules.  By selecting reports, the user tells ASSET what printed and graphic reports to 

generate when running the selected modules.  After running the modules, the selected 

reports are located in their corresponding output windows.  ASSET commands:  SET, 

ONLINE (printed reports) and SET, GRAPHICS (graphic reports) 

 

INDICATOR STATUS-  this command is used to show the values of all indicators used 

by the selected module. 

 

SCALAR STATUS- this command is used to show which scalar parameters used in the 

selected module or 0.0 or “no data”. 
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MACHINERY MODULE WIZARD- this is an interactive module that is used to create 

machinery components. 

 

4.4.4  Ship Menu 

The Ship menu allows the user to manipulate model data.  Figure 4.18 shows the Ship 

menu. 

 

 

Figure 4.18    Ship Menu 

 

USE-  this command brings up a dialog box that enables the user to load a ship or 

component into the current model.   First selecting a ship, then pressing the GROUP or 

PARAMETER command buttons may use a particular parameter or group.  ASSET 

command:  USE 

 

MODIFY-  this command allows the user, via a dialog box, to modify a ship or 

component in the data bank with current model data.   ASSET command:  MODIFY 

 

STORE-  this command allows the user, via a dialog box, to store the current model or a 

portion of the current model as a ship or component, respectively. A particular parameter 

or group may be stored by first selecting a ship, then pressing the GROUP or 

PARAMETER command buttons.  ASSET command:  STORE 

 

REMOVE-  this command is used to delete a ship or component from the data bank.  

ASSET command:  REMOVE 
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4.4.5     Databank Menu 

 

The Databank menu is shown in Figure 4.19.  Following is a description of each menu-

command. 

 

 

Figure 4.19    Databank Menu 

 

ATTACH-  this command attaches a data bank to the user's current session of ASSET.  

The previously attached data bank is closed, but the current model is unchanged. 

 

DESCRIPTION-  this command allows the user to view/edit the Databank Description. 

 

UPDATE-  this command will update the current databank to the current version of 

ASSET. 

 

GENERATE-  this command will generate a new databank. 

 

STATISTICS-  this command displays the contents of the attached data bank and shows 

the amount of utilized space in the data bank. 

 

READ-  this command allows the user to load a command file.  A command file is a file 

that contains ASSET commands.  The commands are executed as the file is read. 
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WRITE-  this command allows the user to write a command file, which contains the 

entire ASSET commands required to create a ship or component. 

 

4.4.6 Utilities Menu 
 

The Utilties menu is shown in Figure 4.20.  Following is a description of each menu-

command. 

 

 

Figure 4.20    Utilities Menu 

 

EXPORT-  this command runs the Export Utility.  This utility allows ASSET to export 

its data to various formats for use by external programs.  See Section 3.5.3 for a 

description of Export capabilities. 

 

CONFIGURE-  this command allows the user to configure add-on utilities.  These 

utilities can be executables or specially designed modules that can interface directly with 

ASSET, or a set of commands that will start another Windows based program from 

within ASSET.  Figure 4.21 shows the Configure Utilities Dialog. 

 

 
Figure 4.21    Configure Utilities Dialog 
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4.4.7    Options Menu 

 

The Options menu contains many of ASSET's program options that the user can set to his 

preference.  Figure 4.22 shows the Options menu. 

 

 

Figure 4.22    Options Menu 

 

SET UNIT SYSTEM: ENGLISH or METRIC- this menu choice will change the unit 

system to the one shown in the menu. 

 

SETTINGS-  this menu choice brings up the Settings dialog box as shown in Figure 4.23.  

The user can specify the various directories, files and Fast Ship information that ASSET 

requires to execute. 

 

Figure 4.23    Settings Dialog Box 

 66 



Section 4  User Interface 

 
START UP-  this options brings up the dialog box shown in Figure 4.24.  In this box, the 

user can include commands that the user wishes to execute at the beginning of every 

ASSET session. 

 

 

Figure 4.24    Start Up Commands Dialog Box 

 

FONTS-  Under this menu item are items that allow the user to set and save the fonts 

used for the active window. 

 

4.4.8    View Menu 

 

The View menu, shown in Figure 4.25, enables the user to hide the tool bar, command 

line, status bar, and the classification marking.  Clicking on the command will toggle the 

bars on and off. 

 

 

Figure 4.25    View Menu 
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4.4.9    Window Menu 

 

The Window menu, shown in Figure 4.26, allows the user to arrange the output windows 

in the default cascaded or tiled arrangement.  The Window menu also allows the user to 

activate and bring any output window to the forefront (the same commands as found in 

the View menu). 

 

 
Figure 4.26 Window Menu 

 

4.4.10 Help Menu 

 

The Help menu, shown in figure 4.27, is the user's avenue by which to obtain on-line 

help and documentation.  Information can be obtained on specific parameters and 

commands.  ASSET's user's manuals are also on-line.  An index has been included for 

easy navigation.  Located on the tool bar is a command button which, when selected, will 

open up the help on a chosen command. 
 

 

Figure 4.27 Help Menu 
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4.5 EDITOR 
 
This section discusses how to input and manage current model data through the ASSET 

Editor.  Included in the discussion are descriptions of the editing functions available as 

well as some examples of how to use the Editor effectively in the ASSET ship design 

environment. 
  
 

4.5.1 Editor Overview 
 
The Editor is the primary method for entering and editing data in the current model.  As 

shown below, there are three sections within the ASSET Editor window, the Command 

Area along the top, the Parameter Tree-View on the left, and the spreadsheet style Data 

Area on the right.  
 

 
 
The Command Area has a text entry field for parameter name searches, and several tools 

for implementing Editor commands. 
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The Name Area section displays the Model Parameter List (MPL) in a tree structure 

similar to the directory tree shown in the Windows Explorer. 

 

The Data Area spreadsheet is very similar to an Excel spreadsheet, but with 

functionality designed specifically to edit the ASSET Current Model data. 

 

4.5.2 Starting the Editor 
 
There are several ways to start the Editor and load data from the current model.  The 

easiest is to use the Editor start button in the Main window tool bar that looks like the 

picture below. 

 
 
It is also possible to start the Editor using the Edit, Open Editor menu option on the Main 

window.  Finally, the Editor can still be started using the old EDIT command, as 

described in Section 3.5, within the Main window tool bar command field. 

 
When started, the Editor will respond by loading the current model into its working 

storage.  To avoid inadvertent destruction of the current model, changes made during an 

editing session will not be written to the current model until the user issues a save 

command.  This feature makes it possible for the user to exit an editing session and leave 

the current model unmodified.  The user may also reinitialize the Editor with unmodified 

current model as long as a save operation has not been performed since the start of the 

editor session. 
 

The name of the ship loaded into the Editor will be indicated in the title area at the top of 

the Editor window.  If more than one Editor window has been opened on the same ship, a 

‘copy’ number will be appended to the ship name, such as ‘Frigate: 2’.  

 

When an Editor window is the active window (title bar highlighted) the program is in the 

Editor-Mode of operation. 
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No matter which way the Editor is started, when an Editor window is open, the Editor 

button in the Main window tool bar looks as if it is depressed as shown below. 

 
 
Please note that if the locations of the three primary working windows (Messages, 

Printed Reports, and Graphic Reports) are set using the Window, Arrange Windows 

option, it is very easy to have an Editor window open and not actually be able to see it. 

The fastest way to determine if an Editor window is already open is to check the status of 

the Editor start button on the Main window tool bar.  If the button is depressed as shown 

above, then an Editor window is already open. 
 

 
 
The standard Window menu option will also show any activated Editor windows by their 

ship name within the listing of the existing windows.  
 

4.5.3 Editor-Mode Program Operation 
 

When an Editor window is open and it is the active window, ASSET is running in the 

Editor-Mode.  In this mode, the menu options at the top of the Main ASSET window are 

slightly different.  Many of the ASSET normal-mode menu options still exist and 

perform the same functions.  Some existing menu options now perform different Editor 
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related functions.  Finally, there are a few new ones that activate special functions only 

available in the Editor-Mode. 
 

Editor-Mode Menus 
 

 
 

 
 

Normal-Mode Menus 
 

 
 
 
The Help, Window, View, and Options menus are unchanged between the Normal-Mode 

and the Editor-Mode. The new Edit-Mode Run menu contains some of the functions from 

the Normal-Mode Module and Utilities menus. 

 

Under the Edit menu, the Cut, Copy, Paste and Clear options now operate on data cells of 

the Data Area when in the Editor-Mode.  A new option is added for the Editor-Mode, 

Import From, whose function is described in the Data Area help 

 

Under the File menu, the Close option works only on the active Editor window when in 

the Editor-Mode. Three additional menu options exist under File when in the Editor-

Mode: Reload from Current Model, Store to Current Model and Properties.  The 

functions of the Reload and Store options are explained in the Data Area help section.  

The Properties option will display the data properties of a parameter that is selected in the 

Name Area. 

 

Finally there is a new main menu item called Format.  This menu provides access to 

display options controls for the spreadsheet Data Area.  With these options provide the 

user control similar to those available in Excel.  The user can set the width of columns, 
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the height of rows, hide/unhide columns/rows, and select from two cell display (view) 

options. 

 

It is possible to enter and execute commands while an editor window is open.  When a 

command is executed and if the editor model has been changed, a prompt dialog will be 

displayed asking to save the editor model to the current model.  The editor does not 

detect changes in the current model.  Care should be taken when executing commands 

while an editor window is open.  Use the Reload button as described in the Command 

Area help section to reload the editor from the current model. 

 

4.5.4 Command Area 
 
The Command Area runs along the top of the Editor window and contains the elements 

shown below. 
 

 
 
 
The field on the far left and the JumpTo button to the immediate right of it are used to 

'jump' down into the tree structure of the Name Area.  In order to 'jump to' a specific 

parameter or group, entered its name into the field and click the JumpTo button.  The 

Editor will then expand the name tree to show that parameter as the selected name.  

When this is done, the value(s) of the selected parameter or group will be displayed in the 

Data Area where it (they) may be edited. 

 

The second button from the left is the Find button and is used for searching the data 

values displayed in the Data Area for a number or string.  These buttons will pop-up a 

standard Find dialog box. 
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The up and down arrow buttons to the right of the Find button are the Previous and Next 

buttons.  These will select the previous or next respectively group or parameter for 

editing.  Selecting the Previous button while editing the first parameter in a group causes 

the group to be selecting for editing.  Selecting the Next button while editing the last 

parameter in a group has no effect. 

 

The Up button causes the parent group of the current group or parameter to be selected 

for editing.  This moves the selection focus up one level in the tree and displays the data 

associated with that name in the Data Area. 
 

The next button group contains the Restore and the Store buttons.  The Restore button is 

used to reload the unmodified current model data into the Editor.  The user will be 

prompted to confirm this operation which will overwrite any changes that had been made 

to the Editor's copy of the data.  The Store button is used to save the modifications that 

have been made in the Editor up to that point to the current model without closing the 

Editor window. .  The Restore and Store functions are also available under the File menu 

when in the Editor-Mode. 

 

The Run button, second from the right, is only active when the Editor is operating in the 

Prompt Mode.  When this button is clicked, it will first ask if the changes to the data 

should be saved and then will rerun the ASSET design/analysis module that had triggered 

the Editor to start up in the Prompt Mode. 
 

The button on the far right hand side is the Close button.  When used, it will first prompt 

the user to save their work and then will stop the Editor and close the window. 

 

4.5.5 Name Area 
 
The Name Area section is left hand windowpane of the Editor window.  Within this pane, 

the Model Parameter List (MPL) is displayed using the Windows standard tree view.  
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The primary function of this area is to select the parameter (or group of parameters) to be 

displayed in the Data Area where it (they) can be viewed and edited.  Pointing at the 

parameter (or group) name with the mouse and single clicking with the left mouse button 

selects the parameter (group). The value(s) of the selected parameter (parameters in the 

group) will then be shown in the spreadsheet view on the right. 

 

The listing within the Name Area shows a hierarchical view of the loaded ship and its 

Model Parameter List. When the Editor is started, the ship name is at the top of the list 

and each of the first level groups is displayed below it in a 'tree view'. 
 

The plus (+) symbols to the left of the group names are used to expand the group to 

display its sub-groups and/or parameters.  Conversely, the minus (-) symbols to the left of 

the group names are used to collapse the sub-groups and/or parameters and display only 

the group name.  The group 'tree' can also be expanded/compressed by double clicking 
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the left mouse button while pointing to the group name.  Parameter names will not have 

the (+) or (-) symbols because they are on the lowest level of the 'tree' structure.  If the 

Editor window is sized too small to display the entire tree, a scroll bar will appear along 

the right side of the Name Area windowpane. 

 

Help on any group or parameter can be obtained by first selecting (single left mouse 

click) the name and then by pressing the F1 key.  This will open the help topic for the 

highlighted group or parameter name. 
 

The separator line between the Name Area and the Data Area can be moved to adjust the 

relative width of each windowpane within the Editor window. 

 

4.5.6 Data Area 
 
This section of the Editor window is where the actual editing of the parameter data is 

done on the parameters that are selected in the Name Area to the left.  The Data Area is 

configured like a spreadsheet with cells that contain data, text, connective, or units. 
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The data cells contain the actual parameter values and are the only cells that can be edited 

by the user using the methods described below.  The remaining cell types have a gray 

background to indicate that the user can not modify them.  The text cells contain the 

parameter names that match the data cells or the connective cells to their immediate right 

in the spreadsheet.  The connective cells are used to switch the display to the next lower 

level within the data structure by displaying the full parameter array or table.  The 

connective cells have a raised 3-D appearance to them (see below) and contain the 

dimensions of the array or table that they are associated with.  The units’ cells display the 

units (feet/meters etc.) in the currently selected unit system of the scalar parameter value 

to the left of it.  Only scalar and array type parameters will display their units in the units 

column.  
 

If there are more rows and/or columns within the selected parameter or group of 

parameters than can be displayed within the available size of the Data Area windowpane, 

appropriate scroll bars will appear.  These scroll bars can be used to scroll (up/down or 
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left/right) within the spreadsheet thus allowing access to all of the selected-parameter 

data cells. 

 

The separator line between the Name Area and the Data Area can be moved to adjust the 

relative width of each windowpane within the Editor window. 
 
 
 
Editing Data 
To edit the value in a given cell, the cell is first selected by pointing at it with the mouse 

and clicking the left mouse button once.  This puts the user into the cell-editing mode and 

the desired value may be typed into the cell using the keyboard.  For scalar and array 

parameters, the values must be numbers, for indicator and table parameters; the values 

are considered characters and must be one of the valid options for that parameter.  See 

the Displaying Parameter Options section below to determine what option values are 

valid.  After entering the desired value, the Enter key is pressed to end the cell-editing 

mode.  If the value entered is invalid, the Editor will blank out the cell shortly after the 

Enter key is pressed. 

 
Displaying Parameter Options 
The indicator and table parameters within ASSET have a fixed set of option values that 

can be used for them.  When a indicator or table parameter is displayed in the 

spreadsheet, double clicking with the left mouse button on the data cell will display a 

pull-down menu button (see below left) on the right side of the cell.  Clicking on this 

pull-down menu button will open a list (see below right) of the valid options.  An option 

can be selected from this list by clicking on it with the left mouse button, followed by 

pressing the Enter key.  
 

    
 
 
Copying, Cutting, and Pasting 
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The copying, cutting, and pasting functions within the Data Area are used much they are 

used in Excel.  Cells are selected by pointing at them and single clicking the left mouse 

button.  Once selected, the cell or cells can be operated on using the pop-up menu opened 

by pointing at a selected cell and clicking the right mouse button once.  The pop-up menu 

list contains the standard Windows Copy, Cut, and Paste. These functions operate just 

like they do in other Windows programs.  The Copy function will copy the selected 

values to the Windows Clipboard but does not change the cell value(s).  The Cut function 

copies the values to the Clipboard and then clears the cell(s) as described in the Clearing 

a Cell section. The Paste function will copy the values stored in the Clipboard into the 

selected cell or cells.  The Copy, Cut, and Paste functions are also available under the 

Edit menu when in the Editor-Mode. 
 

Just like in Excel, an entire row/column may be selected by clicking on the row/column 

number cell located along the left/top edge of the Data Area windowpane.   
 
Clearing (Reinitializing) a Cell 
The Clear is another operation available from the pop-up right mouse-button menu for a 

selected cell(s).  For scalar or array data cells, the Clear operation will set the cell to the 

NO DATA value of 1.0E36.  For indicator and table parameters, the value of the cell is 

set to blank, no characters. .  The Clear function is also available under the Edit menu 

when in the Editor-Mode. 
 
Additional Right Mouse Button Controls 
There are a few special controls and functions that can be reached by using right mouse 

button menu. These functions are specially designed to complete operations within the 

Data Area. 

 

The Insert menu options will insert a row into all of the associate arrays that are 

displayed.  To use this option, first select a row by clicking on the row number on the 

left-hand side of the spreadsheet. While pointing at the selected row, press the right 

mouse button, and select the Insert option.  A blank row will be inserted above the 
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selected row and the rows below will be shifted down.  WARNING: If the array(s) are 

already filled with data, inserting a blank row will cause the last row of data to be lost. 
 

The Delete function will delete one or more rows from all of the associate arrays that are 

displayed. First select the row(s) to be deleted, point at it and press the right mouse 

button and select the Delete option from the menu.  The selected row(s) will be deleted 

and the rows below it (them) will be shifted up to fill in the rows that where deleted. 
 
Import From: 
This option will copy another ship’s value(s) for one or more selected parameters into the 

current model data.  First select a single parameter or group name, or select their 

associated data field(s).  While pointing at the select area, press the right mouse button 

and select the Import From menu option.  A dialog box will appear to allow the user to 

select a ship from the Databank from which to copy the select parameter or group. When 

the dialog box is closed using the OK button, the selected part of that ship will be copied 

into the Editor's copy of the current model.  This function is similar to the Main menu, 

Ship, Use option for using part of a ship.  This function is also available under the Edit 

menu when in the Editor-Mode. 

 
 
New Window: 
This option opens a new Editor window copy of the current ship.  Use this with caution 

because data saving conflicts can occur when more than one Editor window has a copy of 

the current model data. 

 

4.5.7 Prompt Mode Operation 
 
When a synthesis or analysis computational module is run and there is missing or invalid 

data, the Editor is started up in the Prompt Mode of operation.  The invalid or missing 

parameter names is the only ones available in the Name Area and the Data Area will be 

displaying the top most parameter of this invalid data list.  The user then fills in or 

corrects the data for the displayed parameter and presses the Enter key to move to the 
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next item on the list.  Once all of the listed parameters have been edited, or the Run 

button is pressed (see the Command Area topic), the Editor prompts the user to save the 

changes and the computational module that started the Editor Prompt Mode will be rerun. 
 

4.5.8 Multiple Editor Window Operations 
It is possible to have multiple Editor windows activated, each with a different ship 

loaded.  Note that only Editor window(s) of the current model will allow changes to be 

made to the data, all other windows are opened in a Read Only mode.  To open an Editor 

window (Read Only) of a ship in the databank, use the File, Open menu or the Ship, 

Show menu.  A dialog box like below will be displayed to allow the user to select the 

desired ship.  Note that a check box in the lower right corner of the dialog box indicates 

that the Editor copy will be read only 

 
 
Once a copy of a ship is loaded into an Editor window, data may be copied from this read 

only window and be pasted into the current model Editor window.  This can be very 
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useful for transferring portions of one ship into another or for reviewing the values in 

other ships while editing the current model data.   

 

It is also possible to have multiple Editor windows open for the same ship.  The ‘copy’ 

number will be appended to the ship name, such as ‘Frigate: 2’, it the title bar of the 

Editor window.  

4.5.9 Advanced Operations 
 
Column and Row Hiding 
It is possible to temporarily 'hide' a row or column from view within the Data Area.  The 

process is to first select the row(s) or column(s) to be hidden, and then use the Hide 

option located under the Format menu of the Main window when in the Editor-Mode of 

program operation.  This feature can be useful to display two columns or two rows of a 

set of associated arrays at the same time within the Data Area. 
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